'Souls RPG
[resolved] [bug] "View New Posts" not behaving as expected - Printable Version

+- 'Souls RPG (https://soulsrpg.com/forum)
+-- Forum: Out of Character (https://soulsrpg.com/forum/forumdisplay.php?fid=3)
+--- Forum: Roleplay Aids (https://soulsrpg.com/forum/forumdisplay.php?fid=9)
+---- Forum: Bug Reports (https://soulsrpg.com/forum/forumdisplay.php?fid=152)
+----- Forum: Resolved (https://soulsrpg.com/forum/forumdisplay.php?fid=153)
+----- Thread: [resolved] [bug] "View New Posts" not behaving as expected (/showthread.php?tid=51797)



[resolved] [bug] "View New Posts" not behaving as expected - Ems - 29 October 2021

(29 October 2021, 07:07 PM)Songbird Wrote:
(26 October 2021, 12:27 PM)Kiri Wrote:
(24 October 2021, 10:15 AM)Songbird Wrote: Location of Problem: View New Posts & Read/Unread icon indicators
Description of Problem:
I've noticed this a few times now where I'll "View New Posts," look at the ones I'm interested in, and then "Mark All Forums Read" to clear the Unread Thread pink icon indicators.  However, I've noticed that, despite doing this sometimes, the Unread Thread pink icon indicator will still be present on those threads DESPITE those threads no longer showing up in "View New Posts" either?  Usually, it requires me to hit "Mark All Forums Read" a second time to actually clear them of the pink icon indicator.  I never used to have this issue before the mobile updates were rolled? :O

The threads affected are always in different forums/sub-forums.
Link (if applicable): ---

I can't seem to replicate this issue and have no idea how recent updates would affect this. o_o Is it occurring on desktop, mobile, or both?

26 October 2021: I can't reliably get it to replicate either Dx  It's just something I've noticed a few times, and it's usually resulted in me questioning my sanity.  I've always been on desktop when I've noticed it randomly happen.

Re: This issue again, it seems that it may not be related to the "Mark All Forums Read" feature at all?

I haven't "View[ed] New Posts" in probably 6 hours, and there ARE new posts on the forum that I have not looked at yet.  However, when I click "View New Posts," it says that there basically aren't any?  It's like this for both Desktop and Mobile for me; Google Chrome/Firefox for both :O

https://i.imgur.com/PHyWlXM.png

hello! i actually haven't touched the mark all forums read button and still have this issue - and I've noticed it at least thrice in passing, since the removal of the ' read todays posts ' specifically I've noticed it popping up. i have not signed onto souls today and only hit the view new posts the once, and this was my result. 

 link is to a screenshot.


[resolved] [bug] "View New Posts" not behaving as expected - Kiri - 2 November 2021

Re: View New Posts

I've put the "Today's Post" link back into the header menu... I don't know how/why this would affect anything, but let me know if it does or doesn't fix whatever is going on. :V


[resolved] [bug] "View New Posts" not behaving as expected - Ems - 2 November 2021

(2 November 2021, 05:33 PM)Kiri Wrote: Re: View New Posts

I've put the "Today's Post" link back into the header menu... I don't know how/why this would affect anything, but let me know if it does or doesn't fix whatever is going on. :V

Weird, it literally works now. Todays posts, and then view new posts. I am mystified.


[resolved] [bug] "View New Posts" not behaving as expected - Songbird - 3 November 2021

(29 October 2021, 07:07 PM)Songbird Wrote:
(26 October 2021, 12:27 PM)Kiri Wrote:
(24 October 2021, 10:15 AM)Songbird Wrote: Location of Problem: View New Posts & Read/Unread icon indicators
Description of Problem:
I've noticed this a few times now where I'll "View New Posts," look at the ones I'm interested in, and then "Mark All Forums Read" to clear the Unread Thread pink icon indicators. However, I've noticed that, despite doing this sometimes, the Unread Thread pink icon indicator will still be present on those threads DESPITE those threads no longer showing up in "View New Posts" either? Usually, it requires me to hit "Mark All Forums Read" a second time to actually clear them of the pink icon indicator. I never used to have this issue before the mobile updates were rolled? :O

The threads affected are always in different forums/sub-forums.
Link (if applicable): ---

I can't seem to replicate this issue and have no idea how recent updates would affect this. o_o Is it occurring on desktop, mobile, or both?

26 October 2021: I can't reliably get it to replicate either Dx It's just something I've noticed a few times, and it's usually resulted in me questioning my sanity. I've always been on desktop when I've noticed it randomly happen.

Re: This issue again, it seems that it may not be related to the "Mark All Forums Read" feature at all?

I haven't "View[ed] New Posts" in probably 6 hours, and there ARE new posts on the forum that I have not looked at yet. However, when I click "View New Posts," it says that there basically aren't any? It's like this for both Desktop and Mobile for me; Google Chrome/Firefox for both :O

(2 November 2021, 05:33 PM)Kiri Wrote: Re: View New Posts

I've put the "Today's Post" link back into the header menu... I don't know how/why this would affect anything, but let me know if it does or doesn't fix whatever is going on. :V

My "View New Posts" is still messed up? Though, now that I'm looking, I think I may have been using "View Today's Posts" in the past (pre-taking it away) instead of "View New Posts" xD

Either that, or something's changed recently-ish. I had four unread threads in "View Today's Posts," whereas "View New Posts" only showed one of those four (the most recent one)? The "View Today's Posts" was accurate with the actual unread threads I had, the "View New Posts" was not :O


RE: [bug] "View New Posts" not behaving as expected - Kiri - 7 October 2022

Fifty years later, I look at the code for New VS Today's Posts and this is how it's rigged to run:

Toda's posts is very straightforward. It just shows threads whose last post was in the last 24 hours of the time the search is run (link is clicked).

New posts is more weird because it's new posts since the user's "last visit" which is the starting time of a user's last session.

Sessions time out after 15 minutes of inactivity (no clicks on board, so even if you have a tab open with the forum, if you haven't clicked anything in 15 minutes, a new "last visit" time is set once you click something again).

Let's say you visit the board at 12:00 and are active until 12:15. Only posts made after12:00 should show up in New Posts. Posts made prior to your most recent visit aren't "new."

Say 4 posts are made between 12:00 and 12:15. You idle out and return later at 12:30. 10 posts were made between 12:15 and 12:30, while you were away. None of these posts would show up in New Posts.

That's the intended function. Let me know if that's not what's happening. :>