[NEWS] Account Linking & OOC Accounts
#1

Account Linking & OOC Accounts


Account Linking is back and BETTER THAN EVER

  • Link your accounts from UCP>Attached Accounts
  • Switch accounts on the fly from quick reply -- it's RIGHT THERE and easier than ever!
  • Somehow still forget to switch accounts before posting? Switch accounts on posts you've already made (goodbye forever to "wrong account" posts and you don't even have to delete them now) via the little down arrow next to your online indicator at the bottom left of your post.
  • Attached accounts are automatically listed from profiles under "Other Characters" -- right now, the autogen data is listed along with the data from the corresponding profile; the manual profile field will be removed (or replaced?) by the end of the month.
  • Away status set on master account automatically reflected on attached accounts
  • The master account is alerted when a PM is received on an attached account
Please Note
  • You can only switch accounts for posts made from the account you're currently logged into, so if you're logged into A, you can only change posts made by A.

OOC Accounts


There is now a profile field for "Account Type." The default is IC account. IC accounts currently have most OOC information hidden from their profiles. Accounts indicated as "OOC accounts" will display OOC information. OOC accounts with 'show wiki link' checked will link to the Player page of the same name.**

IC/OOC information display in profiles are still being tweaked, so there may be changes and updates in the coming days and weeks. I know the profile fields from UCP are still really messy as well since they aren't separated between IC and OOC fields. Separating out OOC and IC stuff is complicated so I appreciate everyone's patience on this.

** This won't work properly if your OOC account is "Bob" but your appropriate wiki page is actually "Bob 4" :( No way around this except to create a manual field where you paste in a link, but would it be confusing for Bob to link to Bob 4??? What if the Wiki's Bob 1 comes back and then has to create a forum account Bob 2?? Not sure what the best solution for this is... Thoughts appreciated!

OOC accounts are required! Please plan to have your OOC account set up by the end of the month. Remember that account names are required to be a minimum of 3 letters long, so if you have a super short OOC name, you'll need to use a lengthier one, sorry!

Additionally, players are permitted to move one (1) title or icon from an active account to their OOC account for free through the end of the month. After that, they'll require a change token as usual unless the source account is inactive.

When you've created your OOC account, please post in Maintenance to have the account added to the Roleplayer usergroup, which will allow you to edit your "rank." :O (Remember to keep ranks PG-13 and appropriate!) Icon/title moves can also be requested in Maintenance.

Leader characters will retain leader-related privileges on their IC accounts.

If there are any questions or errors/weird things/etc with regard to account linking or OOC accounts, please report HERE! The Migration Log remains for general migration issues and skin/template issues. Thanks!


it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#2
Problem: "Attached Accounts" link top right next to User CP link seems to do nothing when clicked, despite there being an IC account attached to this one :x Possibly me missing something?
  Reply
#3
Quote:Problem: "Attached Accounts" link top right next to User CP link seems to do nothing when clicked, despite there being an IC account attached to this one :x Possibly me missing something?

Try clearing your browser cache or using a different device. If that doesn't work, hit F12 on Firefox or Chrome, go to "Console" on the dialog that pops up, and let me know if there are any errors there.
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#4
(18 August 2020, 11:16 AM)Kiri Wrote:
Quote:Problem: "Attached Accounts" link top right next to User CP link seems to do nothing when clicked, despite there being an IC account attached to this one :x Possibly me missing something?

Try clearing your browser cache or using a different device. If that doesn't work, hit F12 on Firefox or Chrome, go to "Console" on the dialog that pops up, and let me know if there are any errors there.

Thanks Kiri -- hard refresh did it!
  Reply
#5
Would it be at all possible to have the usergroup styling removed from the attached accounts dropdown? At the moment, certain groups—such as Loners and Salsola—are very hard to read against the dark teal background.
  Reply
#6
Quote:Would it be at all possible to have the usergroup styling removed from the attached accounts dropdown? At the moment, certain groups—such as Loners and Salsola—are very hard to read against the dark teal background.

I think this is fixed. May require a cache clear/hard refresh to grab the updated CSS.
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#7
Westy and I have noticed that we are unable to update profile fields. I can't delete/modify what's in the old other characters field, appearance, location, occupation, etc. When I make the changes and click save, it just refreshes the page and there's no difference/my changes are reset to what was there before. I noticed this happening after 1pm central time.

The only thing I see in the console is a warning about loading everything over https.
  Reply
#8
Piggy backing on Myst with more details: it doesn't seem to matter if you're updating text or selecting an option in a drop down box. It just won't save the new data. Where Myst it sounds like, is trying to edit existing info, I'm just trying to add new info altogether on a blank account. Can't do anything at all, lol.
  Reply
#9
Non-saving issue is resolved. Seems like trying to split the fields into categories (OOC/IC) caused it... huge fucking bummer rn but I can't spend more time on this today, so fields are still a mess but at least they save now. .-.
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#10
When logged in on OOC account, I view my profile and when i click on a character listed in Other Characters, it logs me into that character. Going to the profile of the character I'm logged into, I can click on any of the linked other characters/accounts on that profile and it will log me into that account.

So.. if that's not clear:
Logged in as Gen -> Goes to profile page of Gen -> Click Kalypso Savoy -> Page refreshes and I am now logged in as Kalypso Savoy.
  Reply
#11
Quote:When logged in on OOC account, I view my profile and when i click on a character listed in Other Characters, it logs me into that character. Going to the profile of the character I'm logged into, I can click on any of the linked other characters/accounts on that profile and it will log me into that account.

This was the default functionality, but I should've overwritten it... try a cache clear/different device. If that doesn't fix it, pls view source and give me the entire contents of the stuff under "Other Characters".
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#12
^ what Gen said! literally was gonna mention that in this post, haha. i had the same issue when i clicked my other characters; it would switch accounts instead of going to their page. woops ninja'd

also, this might be minor, but the "Attached Accounts" drop-down does not seem to work on mobile. if i click it, nothing happens ;o
STAR PLATINUM
[Image: 278QxiT.png]
  Reply
#13
PHP Code:
<span>Characters:</span><br />
                <
span><!-- startaccountswitcher_profile -->
<
div class="attached-list"><!-- startaccountswitcher_profile_link -->
<!--<
li id="profile_link_3703">--><span class="attached-list"><a href="https://soulsrpg.com/forum/member.php?action=profile&amp;uid=3703"><span class="ln"><strong>Adrianna Julia</strong></span></a></span>
<!-- 
endaccountswitcher_profile_link --><!-- startaccountswitcher_profile_link -->
<!--<
li id="profile_link_4041">--><span class="attached-list"><a href="https://soulsrpg.com/forum/member.php?action=profile&amp;uid=4041"><span class="nc"><strong>Kalypso Savoy</strong></span></a></span>
<!-- 
endaccountswitcher_profile_link --><!-- startaccountswitcher_profile_link -->
<!--<
li id="profile_link_4359">--><span class="attached-list"><a href="https://soulsrpg.com/forum/member.php?action=profile&amp;uid=4359"><span class="sl"><strong>Krios Revlis</strong></span></a></span>
<!-- 
endaccountswitcher_profile_link -->
    <!----></
div>
<!-- 
endaccountswitcher_profile -->
                    </
span
  Reply
#14
(18 August 2020, 03:24 PM)veldt Wrote: ^ what Gen said! literally was gonna mention that in this post, haha. i had the same issue when i clicked my other characters; it would switch accounts instead of going to their page. woops ninja'd

also, this might be minor, but the "Attached Accounts" drop-down does not seem to work on mobile. if i click it, nothing happens ;o

Having the same issue with "attached accounts" doing nothing when you click on it, on Chrome as well, not just mobile.

Also experiencing logging in to IC character's account when clicking character's name within OOC account profile under Other Characters. I have nothing in the "Other Characters" profile field. I'm slow, others already on it. XD
  Reply
#15
Quote:also, this might be minor, but the "Attached Accounts" drop-down does not seem to work on mobile. if i click it, nothing happens ;o

Check that Javascript is enabled.

Otherwise, device/browser? Works for me on Chrome + Android 10. Sims of Firefox and Chrome on iOS also have it working for me. The dropdown menu pushes the border of the page over a bit, but it still works.
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#16
Veldt, you may need to clear the cache for the site on mobile in the privacy settings. This fixed it for me.
  Reply
#17
Quote:When logged in on OOC account, I view my profile and when i click on a character listed in Other Characters, it logs me into that character. Going to the profile of the character I'm logged into, I can click on any of the linked other characters/accounts on that profile and it will log me into that account.

Fiddled with some stuff. This issue still there?
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#18
(18 August 2020, 03:40 PM)Kiri Wrote:
Quote:When logged in on OOC account, I view my profile and when i click on a character listed in Other Characters, it logs me into that character. Going to the profile of the character I'm logged into, I can click on any of the linked other characters/accounts on that profile and it will log me into that account.

Fiddled with some stuff. This issue still there?

Seems fixed to me!
"If at first you don't succeed...try black magic and/or mad science."
  Reply
#19
(18 August 2020, 03:41 PM)Westy Wrote:
(18 August 2020, 03:40 PM)Kiri Wrote:
Quote:When logged in on OOC account, I view my profile and when i click on a character listed in Other Characters, it logs me into that character. Going to the profile of the character I'm logged into, I can click on any of the linked other characters/accounts on that profile and it will log me into that account.

Fiddled with some stuff. This issue still there?

Seems fixed to me!

Fixed here as well
  Reply
#20
(18 August 2020, 03:32 PM)Kiri Wrote:
Quote:also, this might be minor, but the "Attached Accounts" drop-down does not seem to work on mobile. if i click it, nothing happens ;o

Check that Javascript is enabled.

Otherwise, device/browser? Works for me on Chrome + Android 10. Sims of Firefox and Chrome on iOS also have it working for me. The dropdown menu pushes the border of the page over a bit, but it still works.

I'm still having trouble with it. I'm on Chrome on a laptop. >< It gives me a little pointing hand cursor indicating that there SHOULD be some go-to action when I click, but nothing happens when I do. (And just to be certain, we ARE talking about the option for "Attached Accounts" on the main page on the top right of the forum, correct?)
"If at first you don't succeed...try black magic and/or mad science."
  Reply
#21
Quote:I'm still having trouble with it. I'm on Chrome on a laptop. >< It gives me a little pointing hand cursor indicating that there SHOULD be some go-to action when I click, but nothing happens when I do. (And just to be certain, we ARE talking about the option for "Attached Accounts" on the main page on the top right of the forum, correct?)

Yup, we're talking about the same thing. Can you F12 > Console > Paste me any errors there.

Also if you're able to test on another device, that'd be helpful.
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#22
(18 August 2020, 03:58 PM)Kiri Wrote:
Quote:I'm still having trouble with it. I'm on Chrome on a laptop. >< It gives me a little pointing hand cursor indicating that there SHOULD be some go-to action when I click, but nothing happens when I do. (And just to be certain, we ARE talking about the option for "Attached Accounts" on the main page on the top right of the forum, correct?)

Yup, we're talking about the same thing. Can you F12 > Console > Paste me any errors there.

Also if you're able to test on another device, that'd be helpful.

The only thing in Console:

Code:
jquery.js?ver=1820:2 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
send @ jquery.js?ver=1820:2
ajax @ jquery.js?ver=1820:2
(anonymous) @ jquery.tweet.js:269
dispatch @ jquery.js?ver=1820:2
v.handle @ jquery.js?ver=1820:2
trigger @ jquery.js?ver=1820:2
(anonymous) @ jquery.js?ver=1820:2
each @ jquery.js?ver=1820:2
each @ jquery.js?ver=1820:2
trigger @ jquery.js?ver=1820:2
(anonymous) @ jquery.tweet.js:309
each @ jquery.js?ver=1820:2
each @ jquery.js?ver=1820:2
$.fn.tweet @ jquery.tweet.js:256
(anonymous) @ twitter.js:18
e @ jquery.js?ver=1820:2
t @ jquery.js?ver=1820:2
setTimeout (async)
(anonymous) @ jquery.js?ver=1820:2
c @ jquery.js?ver=1820:2
fireWith @ jquery.js?ver=1820:2
fire @ jquery.js?ver=1820:2
c @ jquery.js?ver=1820:2
fireWith @ jquery.js?ver=1820:2
ready @ jquery.js?ver=1820:2
B @ jquery.js?ver=1820:2

And a screenshot of it, just in case: https://i.imgur.com/pii5f11.png

(I never would know to look in these places, lmao, it's scary. XDDD)

I tried it on mobile (Opera) and it isn't working either.

Tried on Firefox on a desktop computer, works beautifully!
"If at first you don't succeed...try black magic and/or mad science."
  Reply
#23
Okay... no errors then. Super weird. :( Not sure what to tell ya other than trying cache clear/hard refresh again. Seems device-related to some extent, but it even works in IE for me, so?? I dunno!
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply
#24
(18 August 2020, 04:13 PM)Kiri Wrote: Okay... no errors then. Super weird. :( Not sure what to tell ya other than trying cache clear/hard refresh again. Seems device-related to some extent, but it even works in IE for me, so?? I dunno!

VERY weird. Definitely agree it's device related. Could it be one of my Ad Blockers perhaps?

How....do I clear cache on Chrome/laptop? XDDD Do you mean dump cookies???

Sooo, for the fuck of it I decided to dig around in the source code see if I could find what the problem was... and I THINK I may I found it.

I saw Javascript mentioned before.....?

[Image: thP71Wr.png]

Now I need to figure out how to re-enable Javascript. I didn't even realize I'd disabled it. O.o


STILL didn't fix it. Javascript IS/WAS enabled, the code lies. I also cleared cookies, didn't fix it. I am at a loss. It just won't work! >_<
"If at first you don't succeed...try black magic and/or mad science."
  Reply
#25
(18 August 2020, 03:36 PM)Gen Wrote: Veldt, you may need to clear the cache for the site on mobile in the privacy settings. This fixed it for me.

ahhh yep, this seemed to fix it! i use samsung internet on my phone (i don't know /why/ i use samsung internet but there you go).

also seems the weird account switching thing is fixed here too and it just goes to their profile, so hooray!  Regparty
STAR PLATINUM
[Image: 278QxiT.png]
  Reply
#26
Are we required to link all of our old/inactive accounts? My list is a mile long since hiding them doesn't affect the account switcher thingy and my active characters are at the bottom. xD
  Reply
#27
I would personally suggest only linking your active accounts -- a player Wiki profile can provide links to previous and inactive characters without causing confusion or cluttering the list vs linking them directly.
“History doesn't repeat itself, but it does rhyme.” ― Mark Twain
  Reply
#28
Kiriiiiiiiii HALP! >< (Yes I am STILL trying to get the fancy new account switcher to work. :( I don't wanna end up being the only poor folk who can't use it.... ) The "Attached Accounts" drop down still is non functional for me in Chrome.

Since deleting cookies, NOW I have different errors (?) showing up in the Console??? 

[Image: 2RyGfzk.png]

P.s. The red error doesn't always appear.

UPDATE: Clearing app cache (Opera browser) on my phone fixed it on Mobile! No luck on Chrome still!
"If at first you don't succeed...try black magic and/or mad science."
  Reply
#29
not sure if i was supposed to put this here but i wasnt able to get an email sent to my email ( i checked everywhere) so can i have someone activate my jmonster OOC account for me please?
[Image: lv7Sq50.png]
Stone the innocents, Know they deserve it.
Rejoice in carnage, Know they deserve it!

Mark my words, Retribution will never come.
  Reply
#30
Quote:Are we required to link all of our old/inactive accounts? My list is a mile long since hiding them doesn't affect the account switcher thingy and my active characters are at the bottom. xD

The only thing that's required is you have an OOC account. :') As Mel said, it's recommended/preferred to just link active accounts.

Quote:Since deleting cookies, NOW I have different errors (?) showing up in the Console???

The yellow error isn't relevant here and the red one implicates Adblock in something so I guess try disabling Adblock on 'Souls? I also recommend uBlock Origin over Adblock Plus in general.
it was me. i broke it.
commission info | twitter | instagram | fb
  Reply


Forum Jump: